gte

Пользователей онлайн: 0.

Праблема з Дэнверам | [Харзах]-[НЕТ]

Аватар пользователя Sergey1917
Автор: Sergey1917 - вс, 20/06/2010 - 15:04

Усталёўваю на Дэнвер копію сайта з хаста. Базу заліваю з дапамогай Sypex Dumper 2. Галоўная старонка запускаецца. Малюнкі праз прэвъю на галоўнай таксама адкрываюцца. А ўсё астатняе няма. Зъяўляецца паведамленне:

Цитата:

Not Found
The requested URL /node/46 was not found on this server.

Подсказка Дэнвера
Вы памыліліся пры наборы URL у браўзары. Хутчэй за ўсё, сервер спрабуе знайсці файл W:/home/мой_сайт.ru/www/node/46, якога не існуе.

В выпадку выкарыстання CGI-скрыптоў, карэктныя шляхі да CGI-дырэкторыям наступныя:

URL Куды паказвае
http://***/cgi-glob/script.cgi /home/cgi-glob/script.cgi
http://***/cgi/script.cgi /home/***/cgi/script.cgi
http://***/cgi-bin/script.cgi /home/***/cgi-bin/script.cgi

--------------------------------------------------------------------------------

Apache/2.2.4 (Win32) mod_ssl/2.2.4 OpenSSL/0.9.8d PHP/5.2.4 Server at www.мой_сайт.ru Port 80


Раньше ўсё адкрывалася. Цяпер навейшая весия Дэнвера варта. бъюся ўжо некалькі дзён.

Владимир, можа вы ведаеце ў чым тут праблема?

Содержание: 
Теги: 

Паспрабаваў зайсці без ЧПУ. Адчынілася акно адмін з папярэджаннем пра адсутнасць у мяне мае рацыю доступу. Пасля ўводу лагіна і пароля зъявілася тое ж самае: Not Found
The requested URL /admin was not found on this server.

Уладзімір, чаму то тут каментары паказваюцца не цалкам. У вашым паведамленні відаць толькі адзін радок, а ад другой ледзь прыкметныя рыскі. А ў маім, відаць два радкі, а ад апошняй (трэцяй), таксама, ледзь прыкметныя рыскі.

наколькі я памятаю, любыя налады сайта можна адключыць прама ў базе дадзеных, табліца variables, калі мне памяць не змяняе ці system... ці можаце спачатку адключыць ЧПУ на сайце ў хостера, потым з дапамогай Сипекс Дампера стварыць бэкап і тд...

насчёт каментароў... мой сайт падтрымліваецца Операй (якой я карыстаюся), Мозиллой і IE6 (якімі я правяраю яго)... калі ў кагосьці IE7-8-9 ці Сафары ці Google Chrome - тое значыць яму не павезла... гэтымі браўзарамі я не карыстаюся наогул і адпаведна, калі яны ў чымсьці не падтрымліваюць нейкія стандарты і з-за гэтага сайт няправільна адлюстроўваецца, то я нічым не магу дапамагчы...

У першых, жадаю падзякаваць за дакладнае вызначэнне маёй праблемы - чыстыя спасылкі. Зайшоў налады чыстых спасылак (праз браўзар) і адключыў. Зарабілі спасылкі ствараныя аўтаматам і па змаўчанні, г.зн. адміністраванне, комменты і інш. А спасылкі, ствараныя для кантэнту ўручную, напрыклад: /noda/30 выводзяць акно: Not Found. Уставіў свой стары файл .htaccess - усё адкрываецца, але чыстыя спасылкі праз админку не ўключаюцца. І на хостынгу паглядзеў, няма файла .htaccess. Паспрабаваў яго заліць, не атрымалася, памылка. А без яго напэўна непажадана?

ну чаму не правільна? проста трэба потым не забыцца, што яны адключаюцца адтуль... а так - няма за што... у мяне на localhost таксама часта ЧПУ не адкрываецца, так што, праблема амаль заўсёды ясная...

З апошняга паведамлення відаць толькі 1-ю радок. Калі скапіяваць, перанесці ў тэкставы рэдактар, то тады можна прачытаць і ўсё паведамленне.

На Друпал.ру паглядзеў пра чыстыя спасылкі - у шматлікіх з імі праблемы ў Друпале. Хворая тэма.

выкарыстоўвайце звычайныя браўзары (Мозилла, Опера) і будзеце бачыць усе радкі... я пра гэта вышэй ужо напісаў, навошта паўтарацца?

проблем з ЧПУ няма... трэба толькі правільна сканфігураваць ці адкампіляваць Апач з ПХП... калі гэтага не ўмець, тады ды - праблемы ёсць... але я не думаю, што гэта так суръёзна на локалхасте, якія ў вас спасылкі, з ?q= ці без...